Attribute rank not found on model

System Information
  • Strapi Version: 4.10.1
  • Operating System:
  • Database: Postgresql 8.10.0
  • Node Version: 16.16.0
  • NPM Version: Windows Desktop 11
  • Yarn Version: 8.11.0

Hello everyone,

I encounter an error on my Strapi following a few database queries.

I specify that I am on Postgresql and that I wanted to reset the id of my table.

(After deleting an article, the ids had a missing id which would have caused me problems in the further development of the project…)

I then searched online for a solution, but to no avail.

I ventured to make queries directly in the database and from my Strapi bug.

Here is what I did:

(Reset the sequence)

(Then update the table’s ID column)
UPDATE drawers SET id = DEFAULT;

It didn’t work, so I tried this command:
truncate drawers restart identify;

Since then I have this error message which does not leave me:

> error: Attribute rank not found on model api::test.test


Do you have a small idea? Thank you for you precious help.

(This is the first time I ask something on a forum)

Rank is a required field for the Drag Drop Content Types plugin I installed.
It was therefore sufficient to create a “rank” number field of type integer in the Content-Type Builder.

The error is solved :slight_smile:

There are some collection types , where i dont want to use “rank” related thing - how i can avoid? why it s forcing to have rank in every collection type?