Can we upgrade Strapi v4.4.5 directly to v4.7?

System Information
  • Strapi Version: 4.4.5
  • Operating System: Windows
  • Database: Postgres
  • Node Version: 16.16.0
  • NPM Version: 8.11.0
  • Yarn Version:

I looked at the migration guides, and you can only upgrade incrementally. Is it safe to go directly from v4.4.5 to v4.7? Any advice is greatly appreciated.

Migration guides:
4.4.5 to 4.5.1
4.5.1 to 4.6.1
4.6.1 to 4.7.0

Thank you.

Strapi recommends you always back up everything before you upgrade in most ceases yes it is always a small change that some edge cease happens and your strapi becomes unusable