Cannot install Strapi CE

System Information
  • Strapi Version:
  • Operating System: Rocky Linux 8
  • Database:
  • Node Version: v10.24.0
  • NPM Version: 6.14.11
  • Yarn Version: 1.22.19

Initially I tried installing Strapi on CentOS 7 but did not succeed.
As I realised that nodejs 18 is not supported on CentOS 7, I then tried on Rocky Linux 8.

Both npx and yarn are unsuccessful to install on Rocky Linux 8.

Any guidance as to how to install Strapi would be appreciated.

npx create-strapi-app@latest my-project
npx: installed 105 in 14.171s
This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). The promise rejected with the reason:
TypeError: lines.flat is not a function
at Paginator.paginate (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/inquirer/lib/utils/paginator.js:31:21)
at ListPrompt.render (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/inquirer/lib/prompts/list.js:121:31)
at ListPrompt._run (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/inquirer/lib/prompts/list.js:73:10)
at Promise (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/inquirer/lib/prompts/base.js:61:12)
at new Promise ()
at (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/inquirer/lib/prompts/base.js:60:12)
at defer (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/inquirer/lib/ui/prompt.js:105:30)
at Observable._subscribe (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/rxjs/dist/cjs/internal/observable/defer.js:8:31)
at Observable._trySubscribe (/root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/rxjs/dist/cjs/internal/Observable.js:41:25)
at /root/.npm/_npx/118528/lib/node_modules/create-strapi-app/node_modules/rxjs/dist/cjs/internal/Observable.js:35:31

yarn create strapi-app my-project
yarn create v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
error inquirer@8.2.4: The engine “node” is incompatible with this module. Expected version “>=12.0.0”. Got “10.24.0”
error Found incompatible module.
info Visit yarn create | Yarn for documentation about this command.

To me that says your node version is 10. Are you sure you are running node 16/18 on Rocky Linux 8.

Just a head’s up you also need buildtools and libvips etc, if it’s not installed for SQLite and sharp module.

You are absolutely right. I got mislead by the Digital Ocean guide because you should not use Option 1 — Installing Node.js with DNF from the Default Repositories… this installs node.js version 10.

It is necessary to use Option 2 — Installing Node.js with DNF Using the NodeSource Repository: only then can you ensure to install version 18.

Thank you!

1 Like