Cannot start Strapi anymore

System Information
  • 4.4.3:
  • Mac:
  • SQlite:
  • Node Version:
  • NPM Version:
  • Yarn Version:

Hi all! I was making some changes in my local Strapi installation, I was changing some content types:

  • Adding/removing fields
  • Added a single type

Later I noticed Strapi was not running. (Another question is: how is this possible) So I tried to start Strapi: Now when I run npm run develop I get the following output (see screenshot) Im running Strapi V4.4.3 and already deleted the node modules folder, cache folder etc and tried again, same result. Any clue on how this can be solved? Google hasn’t helped me yet. (edited)


Did you add a plugin, with something like this in one of the files in the routes folder :

`const { createCoreRouter } = require(’@strapi/strapi’).factories;

module.exports = createCoreRouter(‘plugin::todo.task’);`

Because currently it causes the same error you describe

Thank you for your answer, no I did not add a plugin…

I fixed it by discarding my changes (GIT) and making sure there was no empty collection folder in the src/api/ folder. For me there was an empty folder named product