Chartbrew unable to connect with Strapi

System Information
  • Strapi Version: 4.11.3
  • Operating System: Window
  • Database: PostgreSQL
  • Node Version: 18.16
  • NPM Version: 9.x
  • Yarn Version: 1.22.19

I can’t connect my project with Chartbrew

Like the title, eventhough I’ve closely follow the tutorial by the author himself here. My project somehow kept on saying something wrong with the authentication, thus the log just shown 200 OK. (Domain instead of localhost didn’t work either)
Trying to connect:

I don’t know what do I need to do in order to connect since the log just shown that. Can someone who has experienced advise me please. Thanks

(May I even cc the author: @razvanilin)

Hi there,

I think the issue you are seeing is caused by the default security settings in Strapi. By default, the plugins are only allowed to connect to secure URLs with https and your Chartbrew instance is running locally on http

I wrote a quick guide on how to change these settings over here: GitHub - chartbrew/strapi-plugin-chartbrew: The official Strapi plugin that integrates Chartbrew charts in the Strapi dashboard

Let me know how it goes :v:

Hi pal,
It worked like a charm! Tysm for the response, I’ve setup and wired my dashboard successfully but now 1 minor problem left is that even though my setting for a single chart was “chart size > full width”, it doesn’t actually “full width” over Strapi’s chartbrew tab. I know it’s not under this question but it would be awesome if I got any docs or refs about those FE setup though. Thanks again!

Great to hear it works!

The dashboard and charts in the Chartbrew tab need a polish indeed! Will try and make some time to look into this.

Would you mind explaining what you mean about “FE” docs/refs?