Docker compose launch error

System Information
  • Strapi Version: 4.14
  • Operating System: debian 11 with last docker
  • Database: postgres
  • Node Version: 18+
  • NPM Version: 9.45
  • Yarn Version:

Hello everyone,

I try to install strapi in Docker following the procedure on this post but I have an error when launching the command docker compose up -d at step 5 which launches my next command.

yarn config set network-timeout 600000 -g && yarn install

My procedure :

1 npx create-strapi-app@latest strapi --quickstart
After installation I can access strapi zdmin via xxx.xxx.xxx.xxx:1337
2 CTRL + C for stop app
3 I go to strapi folder and run npx @strapi-community/dockerize
I choose production, postgres db,localhost and generate docker compose.

Once finished, i run docker compose up -d but it’s here what i’m bloked.

I try with root user but i’ts same thing.

Thanks for helping

Sorry, I’m not allowed to edit my message

Here’s the procedure I followed

and here’s the error

user or root@myserver:/home/mcfly/docker/strapi# docker compose up -d
[+] Running 1/1
 ! strapi Warning                                                                                                                                        1.7s 
[+] Building 16.5s (9/13)                                                                                                                                     
 => [strapi internal] load build definition from Dockerfile                                                                                              0.7s
 => => transferring dockerfile: 558B                                                                                                                     0.1s
 => [strapi internal] load .dockerignore                                                                                                                 0.6s
 => => transferring context: 99B                                                                                                                         0.0s
 => [strapi internal] load metadata for docker.io/library/node:18-alpine                                                                                 1.4s
 => [strapi 1/9] FROM docker.io/library/node:18-alpine@sha256:d5b2a7869a4016b1847986ea52098fa404421e44281bb7615a9e3615e07f37fb                           0.0s
 => [strapi internal] load build context                                                                                                                 0.5s
 => => transferring context: 659.37kB                                                                                                                    0.2s
 => CACHED [strapi 2/9] RUN apk update && apk add --no-cache build-base gcc autoconf automake zlib-dev libpng-dev nasm bash vips-dev                     0.0s
 => CACHED [strapi 3/9] WORKDIR /opt/                                                                                                                    0.0s
 => [strapi 4/9] COPY package.json package-lock.json ./                                                                                                  2.5s
 => ERROR [strapi 5/9] RUN npm config set network-timeout 600000 -g && npm install                                                                      10.2s
------                                                                                                                                                        
 > [strapi 5/9] RUN npm config set network-timeout 600000 -g && npm install:                                                                                  
9.095 npm ERR! `network-timeout` is not a valid npm option                                                                                                    
9.112 
9.113 npm ERR! A complete log of this run can be found in:
9.115 npm ERR!     /root/.npm/_logs/2023-07-08T05_53_24_548Z-debug-0.log
------
failed to solve: process "/bin/sh -c npm config set network-timeout 600000 -g && npm install" did not complete successfully: exit code: 1

I tried to run the commands as root or via my user who is not in the sudo group and with commande docker compose up -d --build.

Thanks