Javascript error when accessing "Settings>Users and Permissions Plugin"

System Information
  • Strapi Version: 4.0.2
  • Operating System: Mac
  • Database: sqlite
  • Node Version: 14.17.5
  • NPM Version:
  • Yarn Version: 1.22.5

I have a strange Browser javascript error when I accessing any settings under “Settings>Users and Permissions Plugin”

the error reported in javascript console

TypeError: Cannot read properties of undefined (reading 'allPermissions')
    at p (main.3e964bbd.js:15385:2390)
    at Ch (main.3e964bbd.js:88186:137)
    at ck (main.3e964bbd.js:88296:460)
    at bk (main.3e964bbd.js:88279:347)
    at ak (main.3e964bbd.js:88279:278)
    at Tj (main.3e964bbd.js:88279:138)
    at Lj (main.3e964bbd.js:88272:163)
    at main.3e964bbd.js:88152:115
    at exports.unstable_runWithPriority (main.3e964bbd.js:97973:343)
    at gg (main.3e964bbd.js:88151:325)

I tried both Safari (v14.1.2 ) , and Chrome (v97.0.4692 ) , they report the same error. I tried to remove the database ( sqlite ) and restart the server , and still showing the same error occur.

However, the same code and env is working fine in another server. ( Actually, this error only show up at my production env. local development and staging env are both working fine )

I tried to upgrade to 4.0.4 version, same issue still.

Any clue ?


1 Like