Knex error on deploy using Strapi 4

System Information
  • Strapi Version: 4.0.2:
  • Operating System:
  • Database: Postgres:
  • Node Version: 16:
  • NPM Version: 6:
  • Yarn Version: 1.22:


I’ve been successfully deploying strapi and suddenly, I don’t understand why it returns this error:

error: Knex: Timeout acquiring a connection. The pool is probably full. Are you missing a .transacting(trx) call?

The only changes that I have made have been in the database models, which worked perfectly until now.

Can you help me?

Same error here.
After multiple test i could notice the database timeout as soon as there is a schema modification.
Then it become impossible to deploy online due to the knex timeout issue.
The only way i could bypass the issue was to get the database on your local environment and run it to update the schema within the DB then re upload the updated db online.
The timeout occur only when the json schema is detected as “updated” and trigger a full database check.

Increasing the acquireTimeoutMillis value do not fix the problem neither increase/decrease min/max pool.
moving forceMigration to false also do not have any action

Any permanent fix is welcome.

I also got this error after installing pm2. I wish I had backed up. Now my server won’t start.

Ah, my db server was offline. Turned it on and it is operational again.