Plugin doesn't appear after generating

System Information
  • 3.4.1
  • MacOS 11.0.1 (20B29):
  • mongodb:
  • 12.18.4:
  • 6.14.6:
  • 1.22.10:

On generation new plugin through cli:
strapi generate:plugin <plugin_name>
after this, the new entity doesn’t appear in the sidebar

After generating a new plugin you should build the admin:
yarn build or npm run build.
Also, you can run strapi with –watch-admin flag, in order to start front-end in development mode.

1 Like

Same problem - your reply did not help

If we are talking about v4, then you need to add it to config/plugins.js

This worked for me

  • generate a plugin
  • update config/plugin.js
  • update package.json dependencies “”: “./src/plugins/”

I have tried and experimented, some tutorials in Strapi are believed to be having typos. The plugin file should be “plugins.js” instead of “plugin.js”. “plugin.js” will not be used. I have tried a few times from a plainly generated project to confirm this observation.

1 Like

Thank you king, that was exactly what I needed

Hi all! I found quite good solution to me that looks like common problem.
You need to delete old build folder to force full rebuild of admin ui.