Possible issue updating to 4.0.6 from 4.0.5 and --watch-admin

System Information
  • 4.0.6:
  • MacOS Big Sur 11.4:
  • Postgres:
  • 14.15.4:
  • 8.4.0:
  • 1.22.17:

Hey there,

So I updated today and I can’t seem to get localhost:8000/admin to work now, after running npm run develop – --watch-admin / yarn develop --watch-admin etc. The localhost:8000/ just returns a connection error. It gives me a 8080 port address in the terminal readout when you start the server, through which I can access the strapi dashboard, but it just refreshes and errors when I make a change, and then I have to refresh the page and go back to where I was and it shows the changes. As in, it’s not hot-reloading.

Has anyone else run into this? Am I perhaps doing something silly?


I can confirm to having the same problem. No solution found so far…

Good, at least it’s not just me. I tried creating a new strapi install from scratch and the same issue happens. Anyone got any idea?

Hey, can confirm as well. Having the same issue on 4.0.7, though I can’t even access the dashboard through 8080 - neither on an updated version from 4.0.5 nor on a fresh install on 4.0.7.

Any chance you found a solution so far? I’ve been trying to find all sorts of solutions all day, to no avail…

Hey guys, the problem is persisting but I’ve found a workaround from github.

You’ll have to edit node_modules package, which isn’t great because you’ll have to redo it every time you update strapi. But it works for now.

Go to


Then find (roughly line 52)


Wrap that with

if (!watchAdmin) {

Not 100% sure about the impact on anything, but since it’s dev and only affects when the --watch-admin parameter is set, I don’t think it’ll be a trainsmash.

1 Like

Hey everyone, seems like this is fixed with 4.1.2

1 Like