Problem With A New Instance

System Information
  • Strapi Version: 3.6.8
  • Operating System: Win Local
  • Database: MySql
  • Node Version: v12.22.2
  • NPM Version: 6.14.13

Hi Guys,

I created a new instance of my project. After installation, here’s what happens when I try to login via the login API:

Do you know where the problem is?

Thanks in advance!

Welcome back!
To manage your project 🚀, go to the administration panel at:
http://localhost:1337/maninthemirror
To access the server ⚡️, go to:
http://localhost:1337
[2022-05-04T08:38:52.268Z] error A:\temp\project365\kdp365_be_local\node_modules\redis\dist\index.js:42
            ...options?.modules
                       ^
SyntaxError: Unexpected token '.'
    at compileFunction (<anonymous>)
    at wrapSafe (internal/modules/cjs/loader.js:915:16)
    at Module._compile (internal/modules/cjs/loader.js:963:27)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (A:\temp\project365\kdp365_be_local\node_modules\koa2-ratelimit\src\RedisStore.js:21:15)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (A:\temp\project365\kdp365_be_local\node_modules\koa2-ratelimit\src\index.js:5:20)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.get RateLimit [as RateLimit] (A:\temp\project365\kdp365_be_local\node_modules\strapi-plugin-users-permissions\config\policies\rateLimit.js:5:12)
    at module.exports (A:\temp\project365\kdp365_be_local\node_modules\strapi-plugin-users-permissions\config\policies\rateLimit.js:21:24)
    at dispatch (A:\temp\project365\kdp365_be_local\node_modules\koa-compose\index.js:42:32)
    at module.exports (A:\temp\project365\kdp365_be_local\node_modules\strapi-plugin-users-permissions\config\policies\permissions.js:88:9)
    at async A:\temp\project365\kdp365_be_local\node_modules\strapi-utils\lib\policy.js:68:5
    at async A:\temp\project365\kdp365_be_local\node_modules\strapi\lib\middlewares\parser\index.js:48:23
[2022-05-04T08:38:52.275Z] debug POST /auth/local (4495 ms) 500
^CBatchvorgang abbrechen (J/N)? j
A:\temp\project365\kdp365_be_local>

same question, Have you solved it?

I found a solution to reduce the redis version to 4.0.6

How did you reduce the version?