Strapi config restore is working on local but not on server

System Information
  • Strapi Version: 3.6.2
  • Operating System:
  • Database: mongo
  • Node Version: 14.15
  • NPM Version:
  • Yarn Version: v1.22.10


I have started using strapi and very happy with the features. I was trying to dump the configuration from local and restore it on my server in docker container, but it’s not working. I have tried the same commands on local to restore and its working fine and load the configuration correctly… Below are my script config on package.json.I am using yarn for the same.
“dump:config”: “strapi config:dump -pf strapiConfig.json”,
“restore:config”: “strapi config:restore -s replace -f strapiConfig.json”,

Any suggestions?

Is there any errors in the docker container?

No. I didnt see any error.

Can you explain a bit more what you tried so I can try and reproduce?

sure. I added the mentioned scripts on package.json and ran the dump:config on local. This generated the strapiConfig.json which I pushed to git repo. When I’m deploying it through docker file, I ran the command in below sequence
yarn build
yarn restore:config
yarn start(this has strapi start)
Now when i see the admin panel, configuration is not loaded as I am not able to see the correct order and description for fields which was there on local environment.

can you try to exec into the container and kill the strapi process and try to run the restore?

Thanks for the help. I am able to resolve it by putting everything in start command. like - strapi config:restore -s replace -f strapiConfig.json && yarn strapi start. This works :slight_smile:

1 Like