Strapi file upload - requests timeout since approx. 2 days

System Information
  • Strapi Version: 4.3.3
  • Operating System: ubuntu 22.04
  • Database: postgres
  • Node Version: node v12.22.9
  • NPM Version: 8.5.1
  • Yarn Version: 1.22.19

Hello, as written in the topic I am getting 504 timeout responses since approximately 2 days,
the timeout hits exactly at 1 minute.

I tried accessing the admin panel directly over the port instead of a nginx reverse proxy,
also tried stopping the production build and running strapi in dev mode again.
But so far nothing seemed to fix the problem.

The problem appeared recently without me changing anything.
Still unsure why it failed now, the production build was running smoothly for around 4-5 days,
the whole server setup was done on the 11th August, the problem appeared at around the 14th.

I looked through some forum posts, stackoverflow and some other sites…
but nothing I found helped so far. At the beginning I thought it could be a configuration that was missing for the upload plugin, due to the fact that I store uploaded files locally on the server. But afaik this is supposed to be the default when using strapi without any provider setup. Also I am not using any plugins except the default ones.

Kind regards,
Schuchter W.

Small tip node 14-16 is required for 4.x you are using 12.
HAve youn tried upgrade this first?

Hey Eventyret,

well it seems like the upgrade did the thing.
The problem is gone, didn’t think strapi would even run in an old version.
Still unsure how it was running for a few days and then stopped, but at least now it works again.

Thanks for looking into it.

Kind regards,
Schuchter W.

Glad to hear it works.