Strapi v4.3.9 will run as Typescript

System Information
  • Strapi Version: 4.3.9
  • Operating System: Windows 10 Pro
  • Database: SQLite
  • Node Version: 16.17.0
  • NPM Version: 8.15.0
  • Yarn Version:

My Strapi project in version 4.3.2 ran perfectly without any issue as Typescript project until I upgrade it to version 4.3.9. I followed the migration guide and did all the troubleshooting tips, and still get the same error every time: error: Unknown dialect undefined.

I updated the strapi dependencies in the package.json from 4.3.2 to 4.3.9 and it did not work. So, I manually created a standalone project as an experiment with version 4.3.8 and the same problem occurred.

Is it because Typescript is not supported in Version 4.3.8 or 4.3.9?

Without showing your username and password, what does your /config/database.ts (or /config/database.js) look like?

This is my /config/database.ts content

import path from 'path';

export default ({ env }) => ({
  connection: {
    client: 'sqlite',
    connection: {
      filename: path.join(__dirname, '..', '..', env('DATABASE_FILENAME', '.tmp/data.db')),
    useNullAsDefault: true,

I think I found the problem. The “.tmp” folder and the data.db were never got generated .


Hi this issue due to [4.2 beta] - Error: Unknown dialect undefined on strapi app when start develop · Issue #13237 · strapi/strapi · GitHub

Thank you.