Template Installation failed - Blog quickstart template

System Information
  • Strapi Version: 4 (?)
  • Operating System: Windows 10
  • Database: SQLite (?)
  • Node Version: 16.13.1
  • NPM Version: 7.24.0
  • Yarn Version: 1.22.5

I’m following the guide found here

I run the following command to create a Strapi instance with the blog template

yarn create strapi-app backend --quickstart --template https://github.com/strapi/strapi-template-blog

and get the following error:

C:\Repos>yarn create strapi-app backend --quickstart --template https://github.com/strapi/strapi-template-blog
yarn create v1.22.5
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@2.3.2: The platform "win32" is incompatible with this module.
info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning "gatsby-cli > gatsby-recipes > express-graphql@0.9.0" has incorrect peer dependency "graphql@^14.4.1".
[4/4] Building fresh packages...

success Installed "create-strapi-app@4.0.0" with binaries:
      - create-strapi-app
Creating a quickstart project.
Creating a new Strapi application at C:\Repos\backend.
Creating files.
Error: ⛔️ Template installation failed: Command failed: C:\WINDOWS\system32\cmd.exe /q /s /c "npm view https://github.com/strapi/strapi-template-blog name version --silent"


    at createProject (C:\Users\chris\AppData\Local\Yarn\Data\global\node_modules\@strapi\generate-new\lib\create-project.js:82:15)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async createQuickStartProject (C:\Users\chris\AppData\Local\Yarn\Data\global\node_modules\@strapi\generate-new\lib\create-quickstart-project.js:23:3)
error Command failed.
Exit code: 1
Command: C:\Users\chris\AppData\Local\Yarn\bin\create-strapi-app
Arguments: backend --quickstart --template https://github.com/strapi/strapi-template-blog
Directory: C:\Repos
Output:

info Visit https://yarnpkg.com/en/docs/cli/create for documentation about this command.

Is there something wrong with the template repo and is there a work around to be able to use the blog template for now?

I’m getting this same error. I tried creating and testing a template I created.

However, when i try this command with the strapi/blog template, I also get the same message

Error: :no_entry: Template installation failed: Command failed: /bin/sh -c npm view delux220/strapi-template-comedy name version --silent

Same error

Creating files.
Error: :no_entry: Template installation failed: Command failed: /bin/sh -c npm view next-example name version --silent

Same error here.
did anyone find a solution?

Error: ⛔️ Template installation failed: Command failed: C:\WINDOWS\system32\cmd.exe /q /s /c "npm view https://github.com/strapi/strapi-template-blog name version --silent"

Same error here

Same error here. Following!

Have you found a solution or are you still searching?