There is no "Add Content Type"

Bug report

Required System information

  • Node.js version: 16.17.1
  • NPM version: 8.15.0
  • Strapi version:4
  • Database: MySQL

Describe the bug

This strapi app is deploy on Nodejs server (o2switch) using mysql database. Everything is working but I can’t add content type…

I thought I understood that it was necessary to launch it in local, but I can’t redeploy it… I very lost, how can I use this CMS with nodejs for a nextjs app please ?

Expected behavior

I want to add some single page in order to configure it for my client


You can’t create collection types in production.

The way people mostly do this is run a local version on their machine, add all the schemas so how data is structured.

Then push it to the cloud, add your actual data there.

Thank you for your answer.
I tried to do this but, I don’t really know how to do this. Because on my server strapi is set up with MySQL.
It means I need to connect my local version to the same database as the cloud version in order to set up it well ?

You want to have the two databases.
One for your local development. Adding test data etc.
And in for production where you add actual data.

Thank you a lot I succeed,
but I still have a question, currently I run my local version, do my modifications and then zip the folder, upload it on the server and then extract it and finally run it on the server.
Is it the correct way to push it ?

And thank you again for all

I would say no it depends on how your workflow is.

I don’t do that, I would use git and some github action maybe to do the zipping etc.

I don’t know how your server setup is etc so I can’t really answer it.