Timestamp fields not sanitized by strapi

I haven’t use custom controllers, so must be a bug right ?

“options”: {
“increments”: true,
“timestamps”: false,
“draftAndPublish”: false

Response :

System Information
  • Strapi Version: 3.4.1

You can use privateAttributes for this.

"privateAttributes":["created_at", "updated_at"]


yeah, i know. but i think set “timestamps” option to false is useless because strapi doesn’t drop the columns and doesn’t sanitize too

Strapi never drops columns. It only creates/alters them.