Updated to 3.6.8, can no longer access info

I just upgraded strapi for my personal project from 3.4.2 to 3.6.8, and I exactly followed the migration guide listed on the strapi website. I am the only user/administrator.

Now I’m experiencing a list of deal-breaking issues:

*Collection types are no longer listed in the content types builder, even though they exist

*Can now longer edit data in collection type “No permissions to see this field”

*Clicking to edit a Roles brings me to a blank screen (ie Settings > Roles > Super Admin)

We’ll start there, any help is appreciated thank you.

EDIT: This is on my local development server, not a deploy, if that matters. Thank you.

System Information
  • Strapi Version: 3.6.8
  • Operating System: win10
  • Database:
  • Node Version: 14.15.3
  • NPM Version:
  • Yarn Version:

Are you getting any errors in the console / terminal when it’s starting etc ?

We (the strapi team) have never really been able to reliably reproduce this issue (I’ve tried myself many times). The only known fix I’m aware of is purging the strapi_permissions table in the database and rebooting the app to let it regenerate the default permissions.

You’ll have to go reconfigure any role permissions you had before, that that should solve the issue.

1 Like

Ok thnks. I will try this solution and report back.

Purging the strapi_permissions field didn’t help. Also, I’m not getting errors in the console.

Field? You mean table?

Table indeed.

Can you take a video using something like loom so show the full error and deleting that table + restarting Strapi to regenerate it.

Just to make sure, we’re talking about the data.db file in the .tmp folder?

It’s the only .db file I’m finding.

EDIT: Thanks for trying to help, I will just rebuild my strapi instance from scratch.

Sure, if you are able to reproduce it in the future please do let us know. (But yes I mean the sqlite database since that’s what your using, but it doesn’t matter if it was SQlite or any other database).

Hi @mqpiffle
We have had the same error (No permissions to see this field) after upgrading to version 3.6.8. In our case it was caused by the custom plugin for the content manager (under extensions). I was able to resolve by following the migration guide which states:
" If you are using extensions to create custom code or modify existing code, you will need to update your code and compare your version to the new changes on the repository. Not updating your extensions can break your app in unexpected ways we cannot predict.


I hope this would be helpful for any one facing the same issue.