An error occurred during models config fetch

I had to fix a database to make the Id in alphabetic order. So I exported the data, fixed the information and then imported it but now it gives me the error An error occurred during models config fetch.

Things that I’ve tried but still get the same error:

  • I deleted the table and re-imported the original csv file that exported
  • Same as above but with the new fixed table
  • I went to my local strapi and repushed it to the gcloud app

the data shows up on the backend (using dbeaver) just not showing up in strapi and my app now can’t access it via axios either (error 500)

System Information
  • Strapi Version: “3.1.6”
  • Operating System: macos Catalina
  • Database: gcloud app engine
  • Node Version: “>=10.0.0”
  • NPM Version: “npm”: “>=6.0.0”

Can you share your project and maybe some sample data so I can do some local testing?

I had the same issue.

After I pulled the project from GitHub, I installed the node modules. I also updated the node module, which caused the issue. I didn’t realize, so I deleted the whole project on my laptop and pulled the project again form GitHub. Then I installed node, this time without updating it. Now it works.

It seems that strapi is very dependent on the “correct” node version.

Hope this helps.

Yes we only support the current LTS version of Node and the version of npm it ships with. As of writing this is Node v14 (we do also support Node v12 still) and npm v6 (we do not support npm v7 yet).

We will never support “Odd” Node releases as these will never become stable, IE v13 and v15.

I am using :
strapi : 3.6.8
node : 14.17.6 ( LTS)
npm : 6.14.15

I still facing the same issue.
Also one more issue is that , i have an api created say for “answers” . I can see the list , but when i use pagination( to go to next list) , it gives me this error again → [An error occurred during models config fetch]

Also for other apis , where there are realtions , it doesn’t work and throws this error. It was working on . With 3.6.8 i am facing this same error .

Is your code public (like in a GitHub repo) that I could look at?

Hey ,
I have posted a question on stackoverflow , if this can help ?

However, I am sorry its not on public repo. But I can tell you what’s the issue. In one collection I have a field say : ‘thumbnail’ ( where i save images ) . Earlier , the value for it was a path ( url in string ) to uploads folder location , where the image is . That’s why I am seeing this error.

When I remvoed that thumbnail field , it didn’t show that error anymore, in my model definition about that field it is :
“thumbnail”: {
“model”: “file”,
“via”: “related”,
“plugin”: “upload”

Is it that after 3.0.0 , strapi doesn’t support image url in the field if the type of that field is defined like the one above .?