Blank Admin Page: regeneratorRuntime is not defined (babel?)

System Information
  • Strapi Version: “4.1.7”,
  • Operating System: MacOs
  • Database: SQLLite or Mysql
  • Node Version: v16.14.2 also tried with latest
  • NPM Version: “^6.14.13”, also tried with ^8
  • Yarn Version: 1.22.18
  • Webpack Version: “^5.72.0”

Hi,
we are getting blank admin page and error in browser:

Uncaught ReferenceError: regeneratorRuntime is not defined
at main.eed51f54.js:10011:87836
at Object.423 (main.eed51f54.js:10011:88734)
at e (main.eed51f54.js:10011:94929)
at Object.1261 (main.eed51f54.js:10011:68211)
at e (main.eed51f54.js:10011:94929)
at Object.9321 (main.eed51f54.js:10011:77900)
at e (main.eed51f54.js:10011:94929)
at main.eed51f54.js:10011:94955
at main.eed51f54.js:10011:37
at Object.94344 (main.eed51f54.js:10011:1685)

I’ve been trying to fix this because there is a lot of topic regarding this problem for babel but… I couldn’t reach that place in code because it is placed inside node_modules and strapi babel dependency not whole project dependency.

I’ve already removed /.cache and /build and /node_modules
and running: npm run install and npm run develop
several times trying different solutions and nothing helps
with yarn I was getting some errors during yarn develop so I’ve ended up with npm

Do you have any idea/ solutions? Or maybe previews version of strapi will be fine?

2 Likes

I also have this issue! I got the issue deploying with Heroku. When I updated strapi and made a new strapi project, it went away. Still experiencing the issue while deploying with Heroku, no idea how to fix it.

Hey, I was able to fix the issue. What I did was update to the latest version of strapi and create a new strapi project.

I am getting the same error…
But in my project, there are a lot of changes so if I set up a new project all the changes and Data will be lost.
Does anybody has any solution??

Same problem here - started out of nothing! Seems to be one of the well know strapi issues with dependencies that suddenly stock working :confused:

I redeployed an old commit which was definitely working but due to improper version pinning on strapi dependency side it seems that it stoped working if redeploying the same code again. That’s kinda frustrating because this already happened several time to me with strapi.

After Upgrading strapi and all main plugins to 4.1.9 the error was gone.

2 Likes

I have same issue but after upgrading strapi to 4.1.9 have “Missing jwtSecret. Please, set configuration variable “jwtSecret” for the users-permissions plugin in config/plugins.js”

I have a similar issue.

I reinstalled the app and it worked, but after building some api tables, now all I see is a blank white page.

I’m getting the same issue, with strapi version 4.0.0. Any updates on this issue? Can anyone please share any workarounds? :sob:
when I run yarn develop in my local everything is fine, but when I deployed it on the cloud, it stops working

1 Like

on a fresh install, I have to run yarn build after creating the example-cms project or the blank white screen pops up.

Also, make sure your node is v14+.

Furthermore, this may be related to a plugin problem; do you have any plugins installed? I am leaning to strapi-stripe.

I have had 2 of 2 strapi projects give me this blank page after setting up everything.

Is there a way to backup our content-types?

I am having a similar issue after I get a blank screen I get a different error message

Difference:

My error: TypeError: Cannot read properties of undefined (reading ‘allPermissions’)

I’ve solved it:
just created new project and copy api :slight_smile:

But I didn’t figure this out

You don’t lose any production data that way?

Anyone from Strapi team can help us?

1 Like

In this way, the previous data will be lost, right?

Any Updates?

It’s been a few days now has anyone found a solution or heard anything from the strapi team?

1 Like

I have fixed the issue when I upgraded Strapi version to 4.1.11 and used node=14.19.1 & npm=6.14.16 without creating a new project. Hope this helps you all out too

Hey @webdev did you face the error " [Missing jwtSecret. Please, set configuration variable “jwtSecret” for the users-permissions plugin in config/plugins.js]" ?

@IloveCoding No, but I think you should add JWT_SECRET in your Config Vars and pull the value in config/plugins.js

1 Like

So I did this:

  "engines": {
    "node": "14.19.1",
    "npm": "6.14.16"
  },

Then I ran yarn install (after deleting lock file and node_modules of course)

And I get this error in the console:

λ  The engine "node" is incompatible with this module. Expected version "14.19.1". Got "16.13.2"

Right now you seem to have some success on this issue so I’d like to hear your thoughts on how I should proceed?