Caching in Strapi with REST Cache Plugin

Most firms strive to retrieve and store data faster. It is because no one wants an application that lags. When there's a lot of data in the database, it becomes challenging to fetch data from the database swiftly, which may cause your application to lag. To avoid this, most software firms cache data.


This is a companion discussion topic for the original entry at https://strapi.io/blog/caching-in-strapi-with-rest-cache-plugin

This not working for me. With the same configuration. I am getting this log

[2023-11-23 00:00:22.479] info: File changed: /Users/nitindutta5/Desktop/my-project/backend/config/plugin.js
[2023-11-23 00:00:24.144] info: Using REST Cache plugin with provider “memory”

Put this code before the rest-cache

redis: {
    config: {
      connections: {
        default: {
          connection: {
            host: '127.0.0.1',
            port: 6379,
            db: 0,
          },
          settings: {
            debug: false,
          },
        },
      },
    },
  },