Can insert only two collection-types through http post requests

System Information
  • Strapi Community 3.4.1
  • Ubuntu Server 18.04
  • SQLLite
  • Node v14.15.4
  • npm 6.14.10
  • yarn not installed

Hi strapi community.

I made a fast installation with npx create-strapi-app my-project --quickstart and it’s working properly. But when I try to insert several tables doing http requests, only two collection-types can be inserted.
Can you guys tell me if it can be a problem of strapi configuration? I tried with a digitalocean installation and also local, but the problem persists.

Thank you in advance! :bowing_man:t3:

Can you provide more details please? What do you mean by “insert several tables doing http requests” ?

An example of the code doing this would be useful.

Hey @sunnyson, thank you for replying.

I am doing post requests with a json of the collection-type which I want to create. These json are transcripted by the xml code of an edmx framework file and are properly formatted for strapi.

Here I attach two screenshots.

This are the requests done by strapi when you create a collection-type.

And I tried to replicate those requests with this code.

I hope that this information makes it a little bit clearer.