Cannot login to Strapi admin on Heroku

System Information
  • Strapi Version: 4.1.8
  • Operating System: Mac OS Big Sur
  • Database: Postgres
  • Node Version: 16.13.0
  • NPM Version: 8.1.0
  • Yarn Version: 1.22.18

I have successfully deployed my Strapi admin to Heroku. I followed all of the steps and was able to create an admin account and login to my remote Strapi app and start adding content. It was all working fine. I went away for a bit and when I came back it prompted me to login, but when I tried to login, it keeps saying “Invalid Credentials”. I’m almost 100% sure I am using the correct credentials. So then I tried to use the “forgot password” feature and I put in my email address and it says it will send a link but nothing ever comes. I have tried multiple times and waited well over an hour and nothing comes. How can I reset my admin password on the remote server? I read how I can do it locally, but that doesn’t help me. I also can log into my local instance just fine with the same email and password I used for my remote admin. Is it even possible to reset the password for the Heroku app? It is using Postgres as the database. Is there something I am missing as far as server environment variables and maybe I have something misconfigured in my config scripts? I was able to login fine initially and now I can’t.

Try my solution

Awesome thanks. I was wondering if there was a way to interact with the Heroku app on the command line. This is perfect and good to know. THANKS