Cannot read properties of undefined (reading 'allPermissions')

Hi Guys, anybody knows why my media just blank out something like this?

I’m recent using v4.0.5
Use this package from Lith Vanessa : strapi-provider-upload-google-cloud-storage - npm, version 4.0.0

Please reach and response cause I’m really exchausted about this issue. Thanks in advance.
Oia, I also posted this issue in the official repository on TypeError: Cannot read properties of undefined (reading 'allPermissions') · Issue #123 · Lith/strapi-provider-upload-google-cloud-storage · GitHub. Maybe you want reply too.

I deleted the node_modules folder, removed my yarn and package lock files, then in my package.json file i made sure the versions for strapi, plugin-users-permissions etc. were correct (in my case i corrected them based on the package.json file of a fresh strapi install on my local machine.

Then I ran npm install and pushed to production and it worked … no more white screen or that error in the console!

1 Like

HI, i tried this solution and found that the issue was using npm when i changed my project manager to yarn everything worked fine for all the strapi releases.