Cannot run development mode after creating Heroku production setup

System Information
  • Strapi Version: [v3.5.4] Community Edition
  • Operating System: MacOS BigSur 11.2.3
  • Database: MongoDB (Atlas)
  • Node Version: node v14.16.1
  • NPM Version:
  • Yarn Version: v1.22.10

Hey! So I was trying to create a production setup on Heroku while keeping the dev setup locally. So first I installed Strapi with MongoAtlas locally, which worked just fine. Then I pushed it to github and Heroku and it worked in production mode too. But then when I was trying to run the project locally again, I got the following error:

Error while running command develop: Could not load js config file ./config/._database.js: Invalid or unexpected token
**error** Command failed with exit code 1.
**info** Visit for documentation about this command.

I tried to follow this guide on youtube (Strapi API Deploy to Heroku Step by Step || Strapi Free Hosting with Heroku, Cloudinary and MongoDB - YouTube) , but couldn’t make it work locally after the Heroku setup. What am I missing here?

Easy way to do that you have to re chage your database and cloudinary config file. Check last part of video.