Can't change the Shipper email (users-permissions/email-templates)

Hello everyone ! :alien:

I have been working on a bug for several days without finding any solution.
I am trying to change the Shipper email to
But a 400 Bad request error is returned: “Warning: An error occurred”

And in the console: Invalid template

I thought it was from the Email Designer plugin. But even looking through commits prior to installing this plugin, the problem remains. I even went back to the very first commit of my Strapi (!) and the problem is still there: I cannot modify the email addresses for “Reset password” and “Email Designer” in Settings > Email templates.

Do you have any idea how to proceed? The configuration of ./config/plugins.js is not sufficient, since when registering a user (in front production), the confirmation email seeks to be done with instead mail configured in ./config/plugins.js

Note that the Test email delivery works perfectly locally and in production. So I would like to find a solution to modify the data of the emails present in Email Templates in one way or another.

THANKS FOR YOUR HELP ! :handshake: Have a great weekend everyone :sunflower:

(I’m using Nodemailer, but when I disable it, it doesn’t change anything)

System Information
  • Strapi Version: 4.11.1
  • Operating System:
  • Database:
  • Node Version:
  • NPM Version:
  • Yarn Version:

The ‘Shipper email’ field (and reply-to field) should be set to a valid email address, compatible with the email provider you are using. You say you’re using the Nodemailer provider, so you will have configured that to authenticate with a certain address; the same address must then be put into the templates as ‘Shipper email’ (and reply-to), or your mail service provider may reject the message. Then, too, don’t forget to enable ‘Email confirmation’ under Advanced settings in the Strapi Users plugin.

Your question suggests you’re trying to set a URL instead of an email address … I suspect that’s not what you’re doing, but you might need to rebuild your Admin UI if you’ve changed server-side settings (even if you don’t think they should affect the UI).

Hello, thank you for your answer. My English is bad…
I did not indicate a url instead of an email.

I’m looking to change to (email valid) on the Email Templates page

This email is already present in my configuration (config/plugin.ts):

E-mail: {
     config: {
       provider: 'nodemailer',
       providerOptions: {
         host: env('SMTP_HOST', ''),
         port: env('SMTP_PORT', 465),
         secure: true,
         auth: {
           user: env('AWS_SMTP_USERNAME'),
           pass: env('AWS_SMTP_PASSWORD'),
       settings: {
         defaultFrom: '',
         defaultReplyTo: '',
         testAddress: '',

The Settings > Email > Configuration page works perfectly.
The email delivery test works perfectly.
Confirmation email is enabled (and that’s the problem)

The problem is that when a user registers on
Instead of receiving an email from which would work with Amazon SES. Strapi is trying to send an email from Which generates a 400 error because Amazon SES does not recognize
I need Strapi to no longer send emails with, just

When I go to the console I see that the error raised is invalid template, which seems to be due to the installation of Email designer which modifies the email templates of Strapi.

I wonder if there are other methods to modify the Shiper email than the form present on the Settings > Email templates page…

The solution is to replace the Message content generated by Email Designer in Settings > Email templates with a temporary word in the Message field (or Strapi’s default template), and modify the Sender’s E-mail field. Then click on Finish.

It works ! :heart_eyes_cat:

Then we can go back to Email Designer and find the template that we had deleted. By redisplaying it on Email Designer, it will reactivate in the Message part of Settings > Email templates