Can't install Strapi on Next.js app

System Information
  • Strapi Version: 4.15.0
  • Operating System: Windows 11
  • Database: N/A
  • Node Version: 9.6.3
  • NPM Version: 19.9.0
  • Yarn Version: N/A

Hello there, I’m new to Strapi and this is my first time using it. I urgently need to add its CMS to my Next.js application for a client in a few days.

I’ve tried installing Strapi over and over again using npx create-strapi-app backend but every single time I try I get the same error. I’ve uninstalled and reinstalled npm, node and esbuild, trying different versions, but still nothing works, and I get the same error all the time, its really frustrating.

Heres the error/response I get:

PS G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding> npx create-strapi-app backend
? Choose your installation type Quickstart
You are running Node.js 19.9.0
Strapi only supports LTS versions of Node.js, other versions may not be compatible.
Creating a quickstart project.
Creating a new Strapi application at G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding\backend.
Creating files.
Error while installing dependencies:
npm WARN config production Use `--omit=dev` instead.
npm WARN config optional Use `--omit=optional` to exclude optional dependencies, or
npm WARN config `--include=optional` to include them.
npm WARN config
npm WARN config     Default value does install optional deps unless otherwise omitted.
npm WARN deprecated source-map-url@0.4.1: See
npm WARN deprecated urix@0.1.0: Please see
npm WARN deprecated mailcomposer@3.12.0: This project is unmaintained
npm WARN deprecated @koa/router@10.1.1: **IMPORTANT 10x+ PERFORMANCE UPGRADE**: Please upgrade to v12.0.1+ as we have fixed an issue with debuglog causing 10x slower router benchmark performance, see
npm WARN deprecated source-map-resolve@0.5.3: See   
npm WARN deprecated resolve-url@0.2.1:
npm WARN deprecated formidable@1.2.6: Please upgrade to latest, formidable@v2 or formidable@v3! Check these notes:
npm WARN deprecated buildmail@3.10.0: This project is unmaintained
npm WARN cleanup Failed to remove some directories [  
npm WARN cleanup   [
npm WARN cleanup     'G:\\Workspace\\Chris-Ogbuehis-Monorepo\\FiftyFiftyFunding\\fiftyfiftyfunding\\backend\\node_modules\\@strapi',
npm WARN cleanup     [Error: EPERM: operation not permitted, rmdir 'G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding\backend\node_modules\@strapi\admin\ee\admin\pages\SettingsPage'] {
npm WARN cleanup       errno: -4048,
npm WARN cleanup       code: 'EPERM',
npm WARN cleanup       syscall: 'rmdir',
npm WARN cleanup       path: 'G:\\Workspace\\Chris-Ogbuehis-Monorepo\\FiftyFiftyFunding\\fiftyfiftyfunding\\backend\\node_modules\\@strapi\\admin\\ee\\admin\\pages\\SettingsPage'
npm WARN cleanup     }
npm WARN cleanup   ]
npm WARN cleanup ]
npm ERR! code 1
npm ERR! path G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding\backend\node_modules\esbuild-loader\node_modules\esbuild
npm ERR! command failed
npm ERR! command C:\WINDOWS\system32\cmd.exe /d /s /c node install.js
npm ERR! G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding\backend\node_modules\esbuild-loader\node_modules\esbuild\install.js:130
npm ERR!     throw new Error(`Expected ${JSON.stringify("0.16.17")} but got ${JSON.stringify(stdout)}`);    
npm ERR!           ^
npm ERR!
npm ERR! Error: Expected "0.16.17" but got "0.19.2"   
npm ERR!     at validateBinaryVersion (G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding\backend\node_modules\esbuild-loader\node_modules\esbuild\install.js:130:11)
npm ERR!     at G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding\backend\node_modules\esbuild-loader\node_modules\esbuild\install.js:281:5
npm ERR!
npm ERR! Node.js v19.9.0

npm ERR! A complete log of this run can be found in: C:\Users\Jojo\AppData\Local\npm-cache\_logs\2023-10-31T18_46_16_957Z-debug-0.log
TypeError: Cannot read properties of undefined (reading 'addBreadcrumb')
    at C:\Users\Jojo\AppData\Local\npm-cache\_npx\f5b733dbc92df62b\node_modules\@strapi\generate-new\dist\utils\usage.js:36:31
    at Array.forEach (<anonymous>)
    at Module.captureStderr (C:\Users\Jojo\AppData\Local\npm-cache\_npx\f5b733dbc92df62b\node_modules\@strapi\generate-new\dist\utils\usage.js:35:37)
    at createProject (C:\Users\Jojo\AppData\Local\npm-cache\_npx\f5b733dbc92df62b\node_modules\@strapi\generate-new\dist\create-project.js:133:17)
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
    at async createQuickStartProject (C:\Users\Jojo\AppData\Local\npm-cache\_npx\f5b733dbc92df62b\node_modules\@strapi\generate-new\dist\create-quickstart-project.js:18:3)
PS G:\Workspace\Chris-Ogbuehis-Monorepo\FiftyFiftyFunding\fiftyfiftyfunding>

Please has anyone ever encountered this? Any help would be appreciated.

your note version is not en even version and strapi only suports even versions v18 or v20 are the only 2 sported versions currently.