Can't resolve 'file-saver' in '/workspace/plugins

I installed this plugin for content import and export and for local development it launches and runs smoothly but when I try to deploy it to glcoud it gives me error that I have pasted below. Before this plugin deployment to gcloud worked but I I can’t find the reason why this is happening.

Building your admin UI with development configuration ...
ℹ Compiling Webpack
Error: Module not found: Error: Can't resolve 'file-saver' in '/workspace/plugins/content-export-import/admin/src/containers/ExportPage'
at (/workspace/node_modules/strapi-admin/index.js:70:23)
at finalCallback (/workspace/node_modules/webpack/lib/Compiler.js:257:39)
at onCompiled (/workspace/node_modules/webpack/lib/Compiler.js:265:20)
at hooks.make.callAsync.err (/workspace/node_modules/webpack/lib/Compiler.js:670:21)
at _err1 (eval at create (/workspace/node_modules/tapable/lib/HookCodeFactory.js:33:10), <anonymous>:28:1)
at _addModuleChain (/workspace/node_modules/webpack/lib/Compilation.js:1173:13)
at processModuleDependencies.err (/workspace/node_modules/webpack/lib/Compilation.js:1096:25)
at asyncLib.forEach.err (/workspace/node_modules/webpack/lib/Compilation.js:1017:13)
at /workspace/node_modules/neo-async/async.js:2830:7
at /workspace/node_modules/neo-async/async.js:2830:7
at done (/workspace/node_modules/neo-async/async.js:2863:11)
at /workspace/node_modules/neo-async/async.js:2818:7
at asyncLib.forEach.err (/workspace/node_modules/webpack/lib/Compilation.js:1017:13)
at /workspace/node_modules/neo-async/async.js:2830:7
at /workspace/node_modules/neo-async/async.js:2830:7
at done (/workspace/node_modules/neo-async/async.js:2863:11)
npm ERR! errno 1
npm ERR! wmbold-gcloud-backend@0.1.0 gcp-build: `strapi build`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the wmbold-gcloud-backend@0.1.0 gcp-build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Hi @pinky

As we (the Strapi team) didn’t build or manage that plugin, and the author of the package npm didn’t include a link to their repo I can’t check if the plugin has been updated for the latest release.

oh thank you for checking. This is the link to the plugins repo: GitHub - lazurey/strapi-plugin-content-export-import: Strapi plugin for content export and import

I should mention that it works in local development but when trying to push it to gcloud it’s when it fails.

It looks like they merged a PR for v3.1 but not released a new version: Add icon, name and menu items in plugin definition for compatibility by ozamorowski · Pull Request #14 · lazurey/strapi-

You can instead download that plugin’s code and add it locally into your project under ./plugins. Just make sure you copy any missing dependencies from that plugin’s package.json to your actual project package.json

thank you for the help. Would you put each plugin in their own folder? I’m asking because of the file structure that is listed in strapi’s documentation.

Yup exactly, each in their own folder inside the /plugins

google cloud app is giving me an error and I can’t even figure it out why. Even added the plugins/ folder to my .gcloudignore and it still failed. Guidance on what I need to post to get help on this as they are 34,000 items I would need to upload and I don’t know if there is any other way other than bulk upload to them.

Been working on it for 3days now and can’t figure it out :,(

I’m sorry there isn’t much we can do to assist here since we didn’t build the plugin

oh the issue was being caused by the Documentation plugin. After uninstalling that everything else worked!

O_o? What in the world?

Was that plugin not up to date?

I don’t know I had literally clicked install and everything was installed a few days ago.