Copy Link Media Library not working

Hello community,

I would like to get your help with strapi, I have a problem in the strapi manager specifically in the media library, when I try to copy the link of an uploaded file does not work, nothing happens, I have tried to reinstall the manager, update the version of strapi and still no solution. it would be of great help if I find help here.

System Information
  • Strapi Version v4.11.2:
  • Operating System Linux ubuntu 22.02:
  • Database mysql:
  • **Node Version18.16.1:
  • **NPM Version9.5.1:
  • Yarn Version:


What provider are you using?

hi, i am using local provider

Mind pasting a copy of the link it gives you in chat?

it seems a bug of media library, but these is a work around .
don’t open your strapi via domain address. on your server ,open the strapi via localhost:prot/admin .

Same issue

I have the same issue, but only when it runs on Debian.
When I run it via docker container locally on my windows - everything is working. When I build and run it with exactly the same Dockerfile on Debian (on remote machine) - I have this issue.

I’m using S3 provider (on windows and on debian)

It’s not only media library related - any “copy” button not working:

  • API Token → when I create a token copy button is not working - but it’s ok since i got full token anyway
  • Invite a User → I’m not able to copy invite link, to get the invite token i have to go to the database - it’s real problem.

Do you have the same issue with API Token/Invite user?