Data missing when migrated data from v3 postgres to v4 postgres

System Information
  • Strapi Version: 4.8.2
  • Operating System: Ubuntu
  • Database: PostgreSQL
  • Node Version: 16.19.1
  • NPM Version: 8.19.3
  • Yarn Version:

I tried to migarte the data from v3 to v4 sql using the strapi guide but some of the data is not migrated
In the strapi v3 i have tables :
components_story_group_stories__stories with columns id | components_story_group_story_id | story_id
components_puzzle_group_puzzles__puzzles with columns id | components_puzzle_group_puzzle_id | puzzle_id

I migrated my strapi from v3 to v4 using codemods. And pointed strapi to new empty db and generated schema. After migrating the strapi following changes happen
components_story_group_stories_stories_links with the columns id | group_stories_id | story_id | story_order
components_puzzle_group_puzzles_puzzles_links with columns id | group_puzzles_id | puzzle_id | puzzle_order
**there are more like these tables

When i tried to migrate the data from v3 to v4 the column group_stories_id and group_puzzles_id are skipped
Showing this in the console -
WARNING - items of components_story_group_stories_stories_links was filtered ["group_story_id"]
WARNING - items of components_puzzle_group_puzzles_puzzles_links was filtered ["group_puzzle_id"]
In columns group_story_id and group_puzzle_id NULL value is showing