Data relation issue "initialDataRelations is not iterable"

System Information
  • Strapi Version: v4.5.3
  • Database: Better SQLite package 7.6.2
  • Node Version: v16.18.1
  • Yarn Version: v1.22.19


I am having an issue whereby whenever I try and delete this component from my admin panel it breaks and I get the following error.

So when I run a query for the data in GraphQL, I get the correct response with all the desired data. When I run a REST call it doesn’t return it. I’ve had this issue before and couldn’t resolve it so started from scratch but it appears to always happen with the media field.

This is a production system so quite a breaking change so can’t afford to burn and rebuild.

Tried so far

  • Deleting
    • .cache
    • build
    • node_modules
    • yarn.lock

We run into the same issue. For reference here is the Github Issue: Reordering Relations in Dynamic Zone cause blank screen · Issue #14908 · strapi/strapi · GitHub

Thanks for letting me know! I suspected there would be a GitHub issue raised but wasn’t able to find it. Good to see that 4.6.0 should fix this!