Decrease the time granularity on datetime picker

System Information
  • Strapi Version: 4.2.0
  • Database: Postgres


we are planning to use Strapi to manage Events, so we started to use the datetime picker.

The time dropdown has a granularity of 1 minute. That’s a bit too precise for us and it will slow down the Event creation. I am wondering if it is possible to change that behavior and set 15 minutes or even 30 minutes intervals.

2022-06-24 13_01_04-Content Manager

Thank you in advance for any help or suggestions

You can set the time interval to either 1,5,10,15,30, or 60 minutes inside the Configure the view section. If you’re just starting out, it isn’t very obvious and the documentation isn’t clear for this.

The Configure the view button is on the right above the fields in the Content-Type Builder of each content type.

Once you’ve opened the Configure the view, click the pencil to edit the date field you want to change and you’ll find the Time interval (minutes) option there.


Hi, thank you, in Strapi 4.3.4 is not there.

But I also noticed they released a new version 4.3.5 that implements this feature ( and it’s there now :tada:

Thank you for point that out it will help people looking for this settings.

Has this been removed again from “configure this view”?

I am using the latest build 4.11.7 and it no longer exists:

I think it was removed later from the v4.11.5 as they have introduced input time field instead of dropdown selection. Read this description : Remove time-interval from CTB advanced settings by joshuaellis · Pull Request #1764 · strapi/documentation · GitHub

Ey! I have the same problem. When I try to update config in “Configure the view”, the response show an error related by update in metadatas step. Then, I cannot update other fields view because throw that error. I attached the screenshot in network console.

Reviewing the chore (click here), they said no migrations will be needed but it seems like it won’t work by itself.

Maybe can you offer a solution?


I’ve identified a workaround to address the issue described. Please follow these steps:

  1. Connect to your database.
  2. Navigate to the strapi_core_store_settings table.
  3. Find the row corresponding to the API of the collection you’re attempting to modify. It will resemble something like:
  4. Modify the content of the value column by removing the step field for the field that triggers the error, for example plannedAt.

Once done, you should be able to configure the view without encountering errors.