DigitalOcean database connection failed

Hi Guys,

like last Friday’s webinar, I tried to deploy my Strapi project again.
Unfortunately I got a problem with the database binding.

  1. When I create a PostgreSql database, I get “Connection details are unavailable while the database is being provisioned.” no matter how long i wait.

  1. If I choose an existing database, I get “Database inaccessible”. Unfortunately I can’t find out how to disable “trusted sources” via the link.

Can someone tell me what the problem is. Is there a technical problem on DigitalOcean these days?

Thanks in advance!

hi i think you should install the database your using on the server itself . example : im using mongodb so i installed it and created a database and named it the thing that my strapi app expected me to . you can find that in /config/database.js
im new to deployment as well . you might also wanna check somewhere else i just saw no answers below your question and i wanted to share what i did
good luck !

1 Like

@kouroshtajalliepour Thank you very much for the first time! I’ll test it out this week, then I’ll report whether it worked. :+1:


Hello @mingxi , I am trying to deploy on DO App for the first time and I am facing the same issue. It seems my DB does not get deployed.
Did you find a solution?
Thanks a lot!

Hello, meanwhile I have to give up DO. My project is now on heroku. :wink:

Ok, thanks a lot for your help. I ended up finding the solution myself.
Instead of using pg-connection-string as suggested by Strapi guide I entered all env variables manually.
Now my app is running beautifully and I can even do horizontal scaling out of the box!.

1 Like