Don't load all relations in Content Manager

System Information
  • Strapi Version: 3.6.2
  • Operating System: Heroku?
  • Database: PostgreSQL
  • Node Version: v16.3.0
  • NPM Version:
  • Yarn Version:
Heroku Logs

2021-06-14T16:14:39.620490+00:00 heroku[web.1]: Process running mem=836M(163.4%)
2021-06-14T16:14:39.621837+00:00 heroku[web.1]: Error R14 (Memory quota exceeded)
2021-06-14T16:14:43.930312+00:00 heroku[router]: at=error code=H12 desc=“Request timeout” method=PUT path="/content-manager/collection-types/" request_id=my_id fwd=“my_ip” dyno=web.1 connect=0ms service=30402ms status=503 bytes=0 protocol=https
2021-06-14T16:14:58.025361+00:00 heroku[web.1]: Process running mem=874M(170.8%)
2021-06-14T16:14:58.027286+00:00 heroku[web.1]: Error R14 (Memory quota exceeded)

I’m having troubles using the admin because of a collection type having too many relations.

I have a restaurant collection type, with a relationship to customers, orders and products.

We will soon reach the 15000 order on the website so loading times are above 20 seconds and when I try to modify something in the collection type, the app crashes.

Question: How can I disable the loading of the relations in the content manager so that the admin doesn’t overflow? or I’m doing something wrong?

Thanks for the help!

Related but with no answer: Content manager relations amount showned