Enable responsive friendly upload doesn't work

Continuing the discussion from Enable responsive friendly upload doesn't generate images:

Reposting my question because I didn’t get any answers at all. I am still trying to enable this feature but Strapi does not generate images when I upload images to the media library. I have no idea why it is not working. I have posted my configuration file below, however it is not doing anything at all. Not even the default settings seem to work.

module.exports = ({ env }) => ({
  upload: {
    provider: 'azure-storage',
    providerOptions: {
      account: env('STORAGE_ACCOUNT'),
      accountKey: env('STORAGE_ACCOUNT_KEY'),
      serviceBaseURL: env('STORAGE_URL'),
      containerName: env('STORAGE_CONTAINER_NAME'),
      cdnBaseURL: env('STORAGE_CDN_URL'),
      defaultPath: 'assets',
      maxConcurrent: 10
    breakpoints: {
      large: 1200,
      medium: 800,
      small: 480,
System Information
  • Strapi Version: 3.6.8
  • Operating System: MacOS Sonoma (dev)
  • Database: Postgres 15.5
  • Node Version: v21.4.0
  • NPM Version: 10.2.4
  • Yarn Version: