Error when accessing strapi admin panel

System Information
  • Strapi Version: 4.3.3
  • Operating System: Ubuntu 22.04.1 LTS
  • Database: SQLite
  • Node Version: 16.15.1
  • NPM Version: 8.15.0
  • Yarn Version: 1.22.19


Recently I’ve deployed my strapi app using Nginx and when I’m trying to access admin page I’m getting this error:

I have no idea what does this error means:

TypeError: Cannot read properties of undefined (reading ‘isEE’)

When I’m accessing Strapi app directly by IP and port 1337 everything works fine. I’ve tried many things like deploying the new Strapi app but I can’t figure out what’s wrong.

Any ideas what could be causing this error?

Thanks :blush:


I’ve run into very similar issue. I am trying to start strapi in local environment but i receive the same error. The error starts to throw whenever I try to modify the url property in server.ts. When the property is not set at all, everything works fine.

The solution I am aiming to achieve is to prefix all urls in entire api.

Content of my server.ts

export default ({ env }) => ({
  host: env('STRAPI_HOST'),
  app: {
    keys: env.array('STRAPI_APP_KEYS')

I tried adding ‘/’ at the beginning of url property, but the result is the same.

As for now I am using strapi in version 4.3.2, but I also checked latest strapi version (quickstart) for js and ts and the issue remains.


I also tried to pass to the property an absolute urls, just like documentation says, but it did not solve the issue.

What values I tried:

1 Like

Same problem here… I deleted the .cache and build folder and the admin urls are stuck with /admin/admin slug … I can’t start in local, do you find any solution?

We faced the same issue after using a custom PUBLIC_URL parameter and managed to resolve it after getting back to an empty string value.

1 Like

After changing url from “” to “” the error does not occur. I’ve figured out that error occures only for subdirectory, it works fine with subdomain.