Error when building - self signed certificate in certificate chain

System Information
  • Strapi Version: Latest Buid
  • Operating System: macOS Big Sur 11.6
  • Database: PostgreSQL 13 (Digitalocean)
  • Node Version: v14.18.1
  • NPM Version: 6.14.15
  • Yarn Version:

Hi there,

When I run the command on Mac to build Strapi, I keep getting this error: “self signed certificate in certificate chain”.

I’ve tried trusting the certificate and also disabling the force SSL. Nothing seems to work.

To install Strapi, I’m using “npx create-strapi-app foundry-strapi”. My database is hosted on DigitalOcean, so I’m not using a local DB.

Any help will be appreciated.


If you are creating a new project, I’d recommend using SQLite (quickstart option) then installing the pg package and swapping the configs out with the PG example here: Configurations - Strapi Developer Documentation

The initial testing connection doesn’t yet account for SSL requirements (since by default a local PG instance doesn’t use SSL).

Also I’d strongly recommend that for local development you also use a local database.

1 Like

Hi there,

Thanks, this solved my issue. I tried to install Strapi with the custom config from the start.

After doing the SQL route and then changing the connection string, everything started working.

All solved now.


1 Like

Quite welcome!