Error when trying to install Strapi via npx create-strapi-app@latest my-project --quickstart

This is the error I get. I tried more Node versions still not working.
Anybody faced this issue?

Error while installing dependencies:
npm WARN config production Use `--omit=dev` instead.
npm WARN config optional Use `--omit=optional` to exclude optional dependencies, or
npm WARN config `--include=optional` to include them.
npm WARN config 
npm WARN config     Default value does install optional deps unless otherwise omitted.
npm WARN deprecated urix@0.1.0: Please see
npm WARN deprecated source-map-url@0.4.1: See
npm WARN deprecated resolve-url@0.2.1:
npm WARN deprecated source-map-resolve@0.5.3: See
npm WARN deprecated mailcomposer@3.12.0: This project is unmaintained
npm WARN deprecated buildmail@3.10.0: This project is unmaintained
npm WARN deprecated formidable@1.2.6: Please upgrade to latest, formidable@v2 or formidable@v3! Check these notes:
npm WARN deprecated @koa/router@10.1.1: **IMPORTANT 10x+ PERFORMANCE UPGRADE**: Please upgrade to v12.0.1+ as we have fixed an issue with debuglog causing 10x slower router benchmark performance, see
npm ERR! code 1
npm ERR! path /Users/petrica_b/Documents/Coding/Str/strapi/node_modules/vite/node_modules/esbuild
npm ERR! command failed
npm ERR! command sh -c node install.js
npm ERR! /Users/petrica_b/Documents/Coding/Str/strapi/node_modules/vite/node_modules/esbuild/install.js:132
npm ERR!     throw new Error(`Expected ${JSON.stringify(versionFromPackageJSON)} but got ${JSON.stringify(stdout)}`);
npm ERR!           ^
npm ERR! 
npm ERR! Error: Expected "0.18.20" but got "0.19.8"
npm ERR!     at validateBinaryVersion (/Users/petrica_b/Documents/Coding/Str/strapi/node_modules/vite/node_modules/esbuild/install.js:132:11)
npm ERR!     at /Users/petrica_b/Documents/Coding/Str/strapi/node_modules/vite/node_modules/esbuild/install.js:285:5
npm ERR! 
npm ERR! Node.js v18.19.0

npm ERR! A complete log of this run can be found in: /Users/petrica_b/.npm/_logs/2023-11-30T09_13_25_967Z-debug-0.log
TypeError: Cannot read properties of undefined (reading 'addBreadcrumb')
    at /Users/petrica_b/.npm/_npx/2d56dd13733e9da7/node_modules/@strapi/generate-new/dist/utils/usage.js:36:31
    at Array.forEach (<anonymous>)
    at Module.captureStderr (/Users/petrica_b/.npm/_npx/2d56dd13733e9da7/node_modules/@strapi/generate-new/dist/utils/usage.js:35:37)
    at createProject (/Users/petrica_b/.npm/_npx/2d56dd13733e9da7/node_modules/@strapi/generate-new/dist/create-project.js:133:17)
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)

Ever find a solution to this? I’ve tried three different dev environments and I get some variation of this nonsense every time. “Expected ‘x.xx.xx’ but got ‘x.xx.xx’ at validateBinaryVersion”. It’s driving me insane.