Error while import/export contents from strapi

System Information
  • Strapi Version: 4.14.5
  • Operating System: MacOS
  • Database: Postgres
  • Node Version: 18.14.2
  • NPM Version: 9.5.0
  • Yarn Version:

When Trying to export the contents/ when trying to import the strapi contents from an existing file, I am facing the mentioned error **


Both export/import worked. If you did not use the --no-encrypt flag, you would have to provide the encrypt key that you used during export in order to import the file.

Thanks for your reply. but actually the issue is not with the encryption key. I am getting the error like error: role “strapi” does not exist, even while I try to export contents. Seems like some db related issue. I am running postgres db via docker and is running successfully.
P.S. I dont have any role related to strapi mentioned as above

Blockquote Seems like some db related issue. I am running postgres db via docker and is running successfull

I am not too familiar with docker. I should try to replicate a basic project and see if I get the same issue. @Eventyret have you tried exort/import inside a docker container running Strapi?

Hi, Thanks. It was due to database error. Eventhough I tried to connect to postgres via docker, it was mistakenly pointing to my local postgres server running on my machine. I had to stop that and it worked as expected.

1 Like

Only way to do that will either be to bind mount the folder you export to, OR you will need to SSH or log into the container COPY it out from there which can be a pain.

It also depends on how you have setup the container so without knowing the Dockerfile it will be hard to give this a guess.
Can you use it YES, though you need to do some changes to how the file is setup etc.

1 Like