First Installation Issues [v3.2.1] when using node v14

Having now attempted several times to install strapi for my nextjs project (both yarn & npx, --quickstart & manual) - I am continually encountering the same errors. I have googled, but as yet have found anything related to the displayed errors:

error strapi@3.2.1: The engine "node" is incompatible with this module. Expected version "
>=10.16.0 <13". Got "14.6.0"
error Found incompatible module.

Any suggestions would be welcome.

Many Thanks in advance

Hey @_webmaster welcome,

As the error explains, you don’t have an correct node version. Node v14 isn’t support (yet), this because it isn’t LTS. If you downgrade to v12 you should be able to create a fresh project.

Also there is some testing and CI setup ongoing to support v14 by the end of October, check the tracking issue about it.

Ok. That’s pretty self explanatory - just wanted to check.
Thank you

No problem, a lot of people are already using node v14, but Strapi is dependent on sharp, which wasn’t v14 compatible for a long time. So the start of LTS is a good starting point.