Fresh Strapi install resulting in broken Strapi Admin

System Information
  • Strapi Version: 4.12.0 – Alt, 4.10.7
  • Operating System: Ubuntu 22.04.2 LTS
  • Database: SQLite
  • Node Version: 18.17.0
  • NPM Version: 9.6.7
  • Yarn Version: 1.22.19

I’d like to say I’m somewhat okay navigating my way around Strapi, but this has stumped me…

When I was trying to get a new Strapi instance deployed, I followed the quickstart guide as usual, to get me up and running. This worked, no errors or anything like this. I had a problem where I couldn’t login, but I created an admin user via the CLI and update the config/server.js to have a domain secured (HTTPS).

No matter what I do, if I copy a local Strapi install (v.4.10.7) or start fresh or interchange the versions, I get a very broken and busted Strapi. The admin pages show either infinite loading or blank pages. This is a fresh Ubuntu server as well.

If I visit the content manager, I see this error in the console w/ infinite loading:
TypeError: Cannot read properties of undefined (reading 'components')

If I visit the Content-Type builder I see this error:

{err: TypeError: Cannot read properties of undefined (reading 'reduce')
    at qa (https://subdomain.doma…}

Visiting the Media Library I am greeted with a white page and this in the console:
Uncaught TypeError: Cannot read properties of undefined (reading 'sort')

I’m out of ideas, I can’t find anything on the forums. I’ve cleaned, reset, restarted and deleted many files to just try as many different steps for troubleshooting as I could, but no luck.

I would love to have just copied my local Strapi copy over, but that is not possible from all the different attempts I’ve tried and, at this point- I don’t mind if I have to rebuild it from scratch.

I’m seeking help from the forums to see if anyone else has any other ideas! I also apologize if this isn’t in the right category, or the right place to be asking this.

Did you check the project configuration?

Hia Luis,

Sorry for the delay in my response!

I did check it and I also reinstalled it completely fresh a few times to just double check all sorts of potential problems, but I wasn’t able to find anything sadly :frowning:

The only change I made to the configuration was to put it behind a domain with HTTPS (like because I am not able to set it up by going directly to the IP for example; that process was also broken.

So, that is a production environment, check the documentation about it. Also, you can find some other thread with about deploying on different environments.

It would be helpful to have more information about the system and the Strapi configuration you’re adopting

I’m experiencing the same. Only the homepage of the admin panel works, other pages present the same errors as provided by TS. I am also installing on an existing domain and using https, the only difference is that I reverse proxy to the admin panel on /admin route using nginx, not on a subdomain.

  • Strapi Version: 4.11.1
  • Operating System: Debian 5.10.162-1
  • Database: Postrgres
  • Node Version: 18.17.1
  • Yarn Version: 1.22.19

Which other information should I present?

It works on http via a special port, but given that it’s a production environment, I actually plan to disable http access entirely and only allow access on 443. At this point I have to use VPN to (at least to some extent) securely login and work via http.

Is there a setting that needs to be set somewhere on the Strapi server side to help it resolve assets for non-homepage routes? That’s my suspicion of the cause of these errors anyway.

Setting url on server config didn’t help, same error.

Or maybe a more advanced configuration is required on nginx side?