Getting Strapi errors when I'm trying to start a new Next app?

This is weird. I’m in my projects folder where I keep all of my web projects. I’m simply trying to start a new next app using yarn create next-app and I’m getting a Strapi error.

When working on a Strapi project, I use NVM to set Node to something like 14.17.1. I’m not even using Strapi here though.

Can anybody think of why this might be happening?

Your command should be:
yarn create next-app project-name

Sorry, I should have mentioned that I tried that too. My original command was:
yarn create next-app beer-shop

It threw the same error though.

I got around it by simply using npx create-next-app beer-shop instead, then yarn install once inside the project to start using yarn.

I’m just curious as to what I might have done to make yarn throw Strapi errors when I’m not even using Strapi. It’s likely my fault, something to do with moving my web project folders into a new directory or something but can’t put my finger on it.

Are you trying to boostrap next.js nested within a strapi project?

No, I was just in the general projects directory at ~/Projects/.

The only thing that’s changed recently is that ‘Projects’ used to be named ‘Web Apps’ which simply holds other project folders.