Hey My project currently using the strapi 3.0.0-beta.16.5. Since we need to migrate to Node 18 LTS. Does Node 18 support Strapi 3?

System Information
  • Strapi Version: “3.0.0-beta.16.5”
  • Operating System: “Mac Os Intel Core”
  • Database: “PG Admin”
  • Node Version: “18.6.0”
  • NPM Version: “9.5.1”
  • Yarn Version: “1.22.19”

No you need Strapi V4 for this.
I think V3 will struggle with Node 16

Hey it’s not node 16 which i want to use. I wanted to use Node 18 with strapi v3.

As I said above :slight_smile:
No, you need Strapi V4 for this.

From the V3 docs.

  • Node.js (opens new window): only LTS versions are supported (v12 and v14). Other versions of Node.js may not be compatible with the latest release of Strapi. The 14.x version is most recommended by Strapi.

Where can i get support for migrating the my v3 project to v4??

There is the forums, community discord for the community edition.
There are also some youtube videos and the documentation.

Would be the best place to start.

Hey Getting bellow error if i use v4 with node 18, can someone help me with this?? I have to use node 18 only.

1/5] :mag: Validating package.json…
error check-st@0.1.0: The engine “node” is incompatible with this module. Expected version “>=14.19.1 <=16.x.x”. Got “18.16.0”
error Found incompatible module.

V3 does not support 18 so you will need 16 as the highest or upgrade to 4.