Horrible issue "create-strapi-app@4.1.7"

[details=“System Information”]

  • **S:
  • **Macos 13.5:
  • Database:
  • **Node Version: 20.14:
  • **NPM Version: 10.7.0:
  • **Yarn Version: 1.22.22

I im NOT a strapi user! but I rue the day i tried installingit to give it a try…

ever since then I randomly get an error trying to install packageswith npm & yarn
todays example is this:
error create-strapi-app@4.1.7: The engine “node” is incompatible with this module. Expected version “>=12.22.0 <=16.x.x”. Got “20.14.0”

but its almost identical every time it happens

i’m trying to install something entirely unrelated to strap
namely this command: yarn global add @medusajs/medusa-cli

can anyone here advise me on how to stop this from happening…?