How to disable auto populate for item view?

System Information
  • Strapi Version: 4.0.4
  • Operating System: Ubuntu 20.04
  • Database: Postgres 14.1
  • Node Version: 14.18.1
  • NPM Version: 6.14.15
  • Yarn Version: 1.22.17

Every time I try to open an existing item with more than a few relations (e.g. 20) it takes ages to load and render the item view page. If the relations in the item is +200, in some occasions, I get memory leaks.

  1. Has anyone else experienced this?

I assume this happens because it’s populating the relations. I tried to edit the view and remove the relational data from an item view, but I still get the same issue. I really seems to be a bug

  1. Is there a way to disable auto populate for an item view load?