How to populate a single entry

System Information
  • Strapi Version: 4.3.4
  • Operating System: macOS Monterey
  • Database: SQLite
  • Node Version: v16.3.0
  • NPM Version:
  • Yarn Version: 1.22.17

I’m making a blog with Next.js.
I have the following, rather simple, content setup:

I’m using the REST API to query those posts.

When I query all posts on my collection page with

GET http://localhost:1337/api/posts?populate=*

then I get all posts with all authors.

When I query a single post, which is the only thing I need for my detail page, with

GET http://localhost:1337/api/post/1?populate=*

then I get the post data, but not author data is included.

I checked the Swagger documentation and the populate query parameter doesn’t seem to be supported for getting a single entry, which is surprising to me as a new Strapi user.

Hello you can populate single entry but you need to enable find permission on the author

@zettabyte918 Thanks for your reply!

I just tried that out, but it also doesn’t work.

Just to verify of what I did, I did the following:

  1. I went to the Strapi admin backend → Settings → Users & Permissions Plugin → Roles → Edit the “Authenticated” role.
  2. I went to the permissions section and the find permission on the author and on the post.
  3. I made another REST API call with my API token to GET http://localhost:1337/api/posts/1 and the author was not included in the response.

Also, one thing to note. In the permissions section, when I click on the little cog next to the find permission on the author/post it tells me that the permission is bound to the following 2 API routes respectively:

GET /api/posts
GET /api/authors