I think new Strapi v4 has some problem

I’m trying to install and run new strapi v4 application. But it returns this error.
ModuleNotFoundError: Module not found: Error: Can’t resolve ‘@strapi/design-system/themes’

Module not found means maybe I forgot to install dependencies right?
then I ran npm install
than I tried again npm run develop, and it doesn’t work.
Here I’ve done a post in Stackoverflow - node.js - Strapi V4 Error: Can't resolve '@strapi/design-system/themes' - Stack Overflow

Did you found any solution? I’m facing a similiar problem.

$ npm run gcp-build

> institutional-cms@0.4.2 gcp-build
> strapi build

Building your admin UI with development configuration...

● Webpack █████████████████████████ building (62%) 2/2 entries 2985/3106 dependencies 516/1465 modules 374 active

ModuleNotFoundError: Module not found: Error: Can't resolve '@strapi/icons/CarretDown' in 'C:\Users\xxx\www\xxx-cms\strapi\node_modules\@strapi\design-system\dist\Select'
Did you mean 'CarretDown.js'?
BREAKING CHANGE: The request '@strapi/icons/CarretDown' failed to resolve only because it was resolved as fully specified
(probably because the origin is strict EcmaScript Module, e. g. a module with javascript mimetype, a '*.mjs' file, or a '*.js' file where the package.json contains '"type": "module"').
The extension in the request is mandatory for it to be fully specified.
Add the extension to the request.

I am facing the same issue

I’m not sure what the problem might be but I have found that using a Node version higher than 18, it throws back error.

 debug: ⛔️ Server wasn't able to start properly.
[2022-12-12 10:59:33.458] error: Could not load js config file /Users/treciaks/starter/backend/node_modules/@strapi/plugin-upload/strapi-server.js: 
Something went wrong installing the "sharp" module

Cannot find module '../build/Release/sharp-darwin-arm64v8.node'
Require stack:
- /Users/treciaks/starter/backend/node_modules/sharp/lib/sharp.js
- /Users/treciaks/starter/backend/node_modules/sharp/lib/constructor.js
- /Users/treciaks/starter/backend/node_modules/sharp/lib/index.js
- /Users/treciaks/starter/backend/node_modules/@strapi/plugin-upload/server/services/image-manipulation.js
- /Users/treciaks/starter/backend/node_modules/@strapi/plugin-upload/server/services/index.js
- /Users/treciaks/starter/backend/node_modules/@strapi/plugin-upload/server/index.js

So I used Node v14 and it works well.

treciaks@Trecias-MBP backend % nvm use 14
Now using node v14.20.0 (npm v8.19.1)
treciaks@Trecias-MBP backend % npm run develop

I just solved this problem by changing the import paths to @strapi/design-system/dist/themes’; and ‘@strapi/icons/dist/CarretDown’.

I think the latest Strapi version has a slightly different folder structure adding a dist folder to the paths for these dependencies.