I try to upgrade 3.0.0-beta.20.3 to 3.0.0 my bulid is broken


I have upgraded my strapi version to 3.0.0-beta.20.3 to 3.0.0 my build is broken

Version is upgraded but when I run yarn strapi develop commend below issue is coming


My package.json is

“dependencies”: {
@fortawesome/fontawesome-svg-core”: “^1.2.25”,
@fortawesome/free-solid-svg-icons”: “^5.11.2”,
@fortawesome/react-fontawesome”: “^0.1.7”,
“image-thumbnail”: “^1.0.8”,
“knex”: “latest”,
“koa-range”: “^0.3.0”,
“lodash”: “^4.17.5”,
“react”: “^17.0.2”,
“sharp”: “^0.25.3”,
socket.io”: “^2.3.0”,
“sqlite3”: “latest”,
“strapi”: “3.0.0”,
“strapi-admin”: “3.0.0”,
“strapi-connector-bookshelf”: “3.0.0”,
“strapi-connector-mongoose”: “3.0.0”,
“strapi-plugin-content-manager”: “3.0.0”,
“strapi-plugin-content-type-builder”: “3.0.0”,
“strapi-plugin-email”: “3.0.0”,
“strapi-plugin-upload”: “3.0.0”,
“strapi-plugin-users-permissions”: “3.0.0”,
“strapi-provider-email-sendgrid”: “3.0.0”,
“strapi-utils”: “3.0.0”

please help to fix this issue

As mentioned in other mediums, our recommendation if you are coming from the v3-beta to anything is to create a new project:

@DMehaffy When i upgrade beta to stable coming issue in yarn build

Like this https://prnt.sc/238aoq2

That link doesn’t go anywhere but as I said, we suggest you create a new project and not try to upgrade it. Those guides are quite old and no longer maintained and seeing as you are more than 2 years out of date it is going to take you much much longer to actually upgrade step by step then to just create a new project.

@DMehaffy Okay, I upgraded to 4.0 (https://prnt.sc/23ok540)

I need my all custom module on this new version

My Old version modules are this (https://prnt.sc/23okbe9)

How I transfer this on a new setup?

If you need custom modules I would suggest stay on 3.6.8 for the time been :blush:

@ Eventyret Version issue is fixed now Thank you.

But one thing is still not working, Image upload is not working on the admin panel.


Those liteshot links respond with nothing, can you please just copy paste the image into the forum itself.


Does anyone know why the 3.6.8 version of a Content manager is not showing up?

And How to add custom left menu links for Custom Modules?

That can be any issue. What have you changed?
What is the output on the console in the browser.

I think my best advice is to provide context. If you change things or add custom things please do add this when asking questions. Let us help by helping us.

This is fixed now.

I have another issue when Live mongo DB setup on the new version the post images are not
shown on my old post can you please help on this?