In dev environment (dev machine ) strapi api is taking time to startup (strapi start )

System Information
  • 3.6.8:
  • Windows 10:
  • postgres:
  • v12.19.1:
  • 7.22.0:
  • Yarn Version:

In Dev machine the strapi is taking too much time to start up, This is due to the large number of database queries being executed at the start up.
When setting database debug to true i can see many entries similar to these for different tables.
method: ‘select’,
options: {},
timeout: false,
cancelOnTimeout: false,
bindings: [ 149212, 1 ],
__knexQueryUid: ‘lR0lCG5y1y0Kk7M3kIlIX’,
sql: ‘select “strapi_permission”.* from "strapere “strapi_permission”.“id” = ? limit ?’

Is there a setting to disable firing these queries at start up which makes the startup faster.

With Best Regards

1 Like

@RAMESH_RAJAPPAN Did you ever find a solution or a way to diagnose?