Installation doesn't complete

I’m just trying to use strapi in my Debian bookworm but I can’t reach the web browser interface neither by the create-strapi-app nor a successive npm run develop. I’ve no idea how to troubleshoot this beside having tried nodejs versions v18 and v20 with almost the same outcome.
I also posted on forum:

This topic has been created from a Discord post (1249791014776995943) to give it more visibility.
It will be on Read-Only mode here.
Join the conversation on Discord

app looks like it installs fine but is taking AGES to build the admin

what kind of resources do you have? (RAM wise, ect)

It’s a quite old AMD Phenom™ II X4 945 Processor (a quad core) with 8Gb RAM 400Gb SSD (+ other storage) and GeForce 9600 GT

It’s indeed slow to download and build this strapi thing… :poop:

Oh man yeah those are some really old specs (I haven’t heard of a Phenom since high school), I’m not sure there is much we can do to help you there the build tooling is as bare bones as we can get. Us switching to Vite in Strapi 5 might be easier on your system. Can you try running the Strapi 5 beta and see if that works any better? I wouldn’t advise it for production usage yet but worth trying:

npx create-strapi-app@beta Strapi5Project --quickstart

Thank you I will gladly try Strapi5. I’m also willing to troubleshoot the current release installation since it’s the one used in a course I am attending. I’m sure I can at least come to understand why the browser doesn’t fire, in fact I don’t think it’s just a matter of old hardware

I don’t think the admin is every actually built, hence why the browser doesn’t open because the build never finishes

How can I check if the admin is built?

I ran npx create-strapi-app@beta Strapi5Project --quickstart as you suggested and I went on until npm run develop phase. There it throwed and error which I fixed by issuing npm i ajv-draft-04. Then I tried again npm run develop that ended like the current (non beta) Strapi, that’s to say no browser gets fired and admin url is not available.
The only positive thing is that admin build time is a magnitude faster.

Can you do a npm run strapi report -- --all and provide me the output

It should look something like this:

Launched In: 250 ms
Environment: development
OS: linux-x64
Strapi Version: 4.24.4
Node/Yarn Version: npm/10.2.4 node/v20.11.1 linux x64 workspaces/false
Edition: Community
Database: sqlite
UUID: 70a921c5-ecdb-4e35-bbf6-12635eb181d2
Dependencies: {
  "@strapi/strapi": "4.24.4",
  "@strapi/plugin-users-permissions": "4.24.4",
  "@strapi/plugin-i18n": "4.24.4",
  "@strapi/plugin-cloud": "4.24.4",
  "better-sqlite3": "8.6.0",
  "react": "^18.0.0",
  "react-dom": "^18.0.0",
  "react-router-dom": "5.3.4",
  "styled-components": "5.3.3"
Dev Dependencies: {}

Same here.

Using Node.js v18.18.0, I ran:
npx create-strapi-app@beta Strapi5Project --quickstart

I got:

  throw err;

Error: Cannot find module 'ajv/dist/core'

Then I Ran:
npm run strapi report -- --all

But got the same error:

Error: Cannot find module 'ajv/dist/core'
Require stack:

It might be related to the issues we have with NPM, I assume both of you don’t have yarn installed do you?

I do have yarn installed on my computer. But I do not know how to create a project from scratch using yarn. Just using npx.

It’s not you all, we were testing a fix earlier today and it’s still broken, for now I’d suggest using beta.9 instead

npx create-strapi-app@5.0.0-beta.9 myStrapi5App

`node@node:/run/host/var/www/nextjs-course/blog/backoffice_strapi5_node20$ npm run strapi report – --all

backoffice-strapi-5-node-20@0.1.0 strapi
strapi report --all

Illegal instruction

It seems the responsible of the illegal instruction error is the package sharp which is pre-built for selected architectures, not yet available for amd64. I will try to understand if it’s possible at all to build sharp for amd64.